Recertify your expired Professional level certification with the new CWS-315 course!  

Security training for IT professionals, regardless of their area of specialization, can help to close skills gaps. CWS-315 Citrix Virtual Apps and Desktops 7 Advanced Deployment, Troubleshooting Security and Administration was developed to emphasize security skills for skills for on-prem and cloud virtualization environments.

At the same time, you can receive a skills refresher with our latest training and automatically recertify your expired or expiring CCP-V certification by attending the CWS-315 training course. This means you will not need to take and pass the equivalent exam!

You must sit the class no later than December 31, 2019.

Let Citrix Education help you on your learning journey!