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Introduction
Citrix XenDesktop™ is a desktop virtualization  and VDI solution that deliv-
ers a complete Windows desktop experience as an on-demand service to any 
user, anywhere. Whether users are task workers, knowledge workers or mo-
bile workers, XenDesktop can quickly and securely deliver individual applica-
tions or complete desktops while providing a high-definition user experience. 
All of this is made possible by FlexCast™ delivery technology that enables 
IT to deliver any type of virtual desktop, on any device. With XenDesktop, 
IT can manage single instances of each OS, application and user profile and 
dynamically assemble them to increase business agility and simplify desktop 
management.  By deploying a desktop virtualization solution, companies can 
migrate to new versions of Operating Systems, such as Windows 7, quickly, 
efficiently and cost-effectively. 

XenDesktop makes virtual desktops a mainstream reality for hundreds of mil-
lions of corporate employees for the first time ever. Unlike first-generation 
virtual desktop (VDI) solutions that were applicable only to a narrow set of 
users, XenDesktop with its new FlexCast delivery technology is the first prod-
uct in the industry to support every desktop virtualization model in a single, 
integrated solution. This approach improves ROI, simplifies management and 
extends the benefits of virtualization to every employee in the enterprise. With 
the full integration of Citrix XenApp™ functionality, customers can deliver 
on-demand applications as a seamless part of their overall desktop manage-
ment strategy.

Citrix XenDesktop™, a member of the Citrix Delivery Center™ product fam-
ily, is a comprehensive desktop delivery system that allows customers to vir-
tualize Windows desktops in the datacenter and deliver them on-demand to 
office workers in any location. By dynamically assembling each user’s unique 
personal desktop from new, pristine components each time they log on, 
XenDesktop offers an unparalleled end-user experience, dramatically simpli-
fies desktop management and reduces the cost of traditional desktop com-
puting by up to 40 percent. XenDesktop Enterprise and Platinum Editions 
tightly integrates the industry’s most proven application virtualization via the 
XenApp for Virtual Desktops feature. 

When using the Web Interface, Applications and Desktops are delivered 
through Internet Browsers to the client device.  When using the Citrix Online 
Plugin, Applications and Desktops are delivered through the Citrix Online 
Plugin on the client device.

This guide will walk through the steps to deploy a complete XenDesktop en-
vironment.

�
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Solution Requirements
Windows Desktops delivered to Clients - regardless of client operating sys-
tem.

Fast Delivery of XenDesktop

Prerequisites
Citrix XenDesktop 4.0+

Citrix Branch Repeater Solution v5.6+

Citrix XenServer 5.5+ (500 Gb Storage)

Citrix XenCenter 5.5+

Microsoft Windows Server 2003 x32bit (AD, DHCP, DNS)

Microsoft Windows Server 2003 x32bit (XenDesktop DDC)

Microsoft Windows Server 2003 x32bit (XenDesktop PVS)

vBaseDesktop1 (Windows 7 XenDesktop Base Image)

vDesktop1 through vDesktop5 (Windows 7 Virtual Desktops)

Clients

Additional Information
http://flexcast.citrix.com/
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The following is the Network that was used to develop this deployment guide.

Network Diagram
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Virtual machine IP Address
Gateway 10.217.104.1/24

Active Directory, DHCP, DNS 10.217.104.200

XenDesktop DDC 10.217.104.201

XenDesktop PVS 10.217.104.202

XenApp 10.217.104.205

BR VPX Datacenter 10.217.104.206

BR VPX Remote 10.217.104.207

DHCP Range 10.217.104.210-.240

XenCenter PC 10.217.104.105

XenServer Datacenter 10.217.104.12

XenServer Remote 10.217.104.13
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Connect to XenServer: 
From the XenCenter PC, 
Launch XenCenter and connect 
to the XenServer.

XenServer
Install Citrix XenServer on the server that will run the XenDesktop Infra-
structure. Install Citrix XenCenter on a PC to manage the XenServer and 
XenDesktop environment.  
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XenDesktop
Windows Server 2003 Base Image

To create the Virtual Desktop Infrastructure (VDI), we will start by creating 
a base Windows 2003 server image, install SP2, and all Operating System up-
dates.  This image will be used to create the XenDesktop DDC, XenDesktop 
Provisioning Server and Domain Controller.

�

Windows Server Base 
Image:
Create a new VM of Windows 
Server 2003 x32.

Note: The OS can be installed 
from the XenServer CD/DVD 
Drive or an ISO image.

Name: W2K3 x32 Base Image

vCPUs: 1

Memory: 1024 Mb

Disk: 10 Gb

Network: Interface 0 (minimum)

Right-Click the W2K3 x32 
Base Image in the left panel of 
XenCenter.

Install XenServer Tools.

Log into the W2K3 x32 Base 
Image and launch the installer 
from the CD drive.

Reboot.
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Remote Desktop:
Log into the Windows Server 
through the XenCenter 
“Console” tab.

Enable RDP:

Start -> Right-Click My 
Computer -> Properties -> 
Remote -> Enable Remote 
Desktop.

In the Windows Network 
Settings, disable the Firewall.

If you don’t want to install FTP 
as part of Internet Information 
Service, you can use other FTP 
tools such as FileZilla:

http://filezilla-project.org/

Install Service Pack 2.

Install Operating System 
Updates.

Make sure .NET 3.5 Framework 
is installed.

Certificates MMC:
Launch the Microsoft 
Management Console and 
install the Certificates Snap-In.

Start -> Run -> MMC.

File -> Add/Remove Snap-In -> 
Add -> Certificates -> Add -> 
Computer Account.

Finish, Close and save the 
MMC to the C:\ drive.

http://filezilla-project.org/
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Sysprep: 
Open Windows Explorer and 
navigate to the W2K3 install 
CD/DVD drive, \Support\Tools 
directory.

Open the Deploy.cab file.

Select setupcl.exe and sysprep.
exe, and copy them to the C:\ 
drive.

Navigate to the C:\ drive, and 
launch the sysprep.exe utility.

Select Shut Down for Shutdown 
mode.

Select Reseal.

Ok.

Allow the server to shutdown.
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Convert to Template: 
Wait until the server has shut 
down completely.

In the left panel of XenCenter 
select the W2K3 x32 Base 
Image -> Right-Click -> Convert 
to Template.



DEPLOYMENT GUIDE  |  XenDesktop

12

Domain Controller - vDesktopDC

Create the Domain Controller that will host Active Directory, DHCP, DNS 
for the XenDesktop environment.  Note: If you already have a DC, you can 
use that one.

Domain Controller:
From XenCenter select -> VM 
-> New VM.

Select the W2K3 x32 Base 
Image created in the previous 
step.

Name: vDesktopDC

vCPUs: 1

Memory: 1024 Mb

Disk: 10 Gb

Network: Interface 0 (minimum)

Follow the steps to complete 
the sysprep installation process.

Login as the local Administrator.
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Network Settings:
Open the Network Settings in 
the Control Panel.

Assign a static IP Address to 
the Network Interface.  

In this example:

IPA: 10.217.104.200

NMK: 255.255.255.0

GWY: 10.217.104.1

DNS: 127.0.0.1

Note: Disable the firewall.

XenTools: 
Install XenTools.

Select the vDesktopDC from 
XenCenter left panel -> Right-
Click -> Install XenServer Tools.
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Remote Desktop: 
Connect to the Domain 
Controller using RDP.

From the XenCenter PC, Start 
-> Run -> cmd.exe.

Within the command prompt 
window, launch Microsoft 
Terminal Services:

c:\mstsc /console

Enter the IP Address of the 
Domain Controller.

Rename Computer: 
Right-Click on My Computer 
and change the computer name 
to vDesktopDC.

Restart.
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Domain: 
Enter the domain name you 
plan to use.

DC Role: 
Install the Domain Controller 
Role.

Start -> Administrative Tools -> 
Configure Your Server Wizard.

Install the Domain Controller.
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DNS:
Install DNS on this machine.

Restart.

Reconnect using RDP.

Login to the Domain:
From this point forward it 
is important to login to the 
Domain account on each 
computer that has joined 
the Domain - otherwise the 
configuration of DDC and PVS 
will not work.
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DHCP:
Install the DHCP service.

Start -> Administrative Tools -> 
Manage Your Server.

Add Role.

DHCP.

Enter DHCP IP Address Range.

Enter a Default Gateway.

Reverse Lookup Zone:
Configure a Reverse Lookup 
Zone in DNS.

Start -> Administrative Tools -> 
DNS.

Select Reverse Lookup Zones.

Add a New Zone from the 
Action Menu.

Follow the New Zone Wizard.
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DHCP:
Parent Domain: xencloud.net

Server Name: vDesktopDC

Click on Resolve.

Add.

Bypass WINS by clicking Next.

Activate the Scope.

DHCP Authorize:
Authorize the DHCP Server.

Start -> Administrative Tools -> 
DHCP.

Right-Click vDesktopDC in the 
right panel -> Authorize.

Action -> Refresh.
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Option 66: 
With DHCP still open, select 
Server Options and Right-Click.

Configure Options.

Scroll Down and select 066 
Boot Server Host Name.

Enter the IP Address of 
the Provisioning Server - 
vDesktopPVS (Note: The PVS 
has not been created yet).

Option 67: 
Scroll Down and select 067 
Bootfile Name.

Enter the String ARDBP32.bin 
in the String Value field.

Select Apply.

Ok.
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Test User Accounts: 
Add some test user accounts.

Start -> Administrative Tools -> 
Active Directory.

Create five user accounts:

user1

user2

user3

user4

user5

OU:
Select the Xencloud.net server 
in the left panel.

Right-Click.

New.

Organizational Unit.

Name: XenDesktop

Reboot the server.
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Certificate Services: 
Install Certificate Services on 
the Domain Controller.

From the Control Panel -> 
Add or Remove Programs 
-> Windows Components 
-> Certificate Services -> 
Enterprise CA.

Common Name: xencloud

Accept the defaults.

Desktop Delivery 
Controller:
Time is of the essence.

Make sure the Date and 
Time are set correctly on the 
Domain Controller.  The PVS 
and DDC sync time when they 
authenticate with the DC.

If the Date and Time are off, the 
vDisk will not start.
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Desktop Delivery Controller - vDesktop-
DDC

Create the Desktop Delivery Controller, join the Domain and add the Domain 
Controllers root certificate.

Desktop Delivery 
Controller:
From XenCenter select -> VM 
-> New VM.

Select the W2K3 x32 Base 
Image created in the previous 
step.

Name: vDesktopDDC

vCPUs: 1

Memory: 1024 Mb

Disk: 10 Gb

Network: Interface 0 (minimum)

Follow the steps to complete 
the sysprep installation process.

During Windows Setup, set the 
Computer Name:

vDesktopDDC

Don’t join the Domain yet.

Login as the local Administrator.
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Network Settings:
Open the Network Settings in 
the Control Panel.

Assign a static IP Address to 
the Network Interface.  

In this example:

IPA: 10.217.104.201

NMK: 255.255.255.0

GWY: 10.217.104.1

DNS: 10.217.104.200

Note: Disable the firewall.

XenTools: 
Install XenTools.

Select the vDesktopDDC from 
XenCenter left panel -> Right-
Click -> Install XenServer Tools.
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Remote Desktop: 
Connect to the DDC using RDP.

From the XenCenter PC, Start 
-> Run -> cmd.exe.

Within the command prompt 
window, launch Microsoft 
Terminal Services:

c:\mstsc /console

Enter the IP Address of the 
DDC.

Note: Make sure you login to 
the Domain, and not the local 
computer account.

Join Domain: 
Join the Domain.

Start -> My Computer -> Right-
Click -> Properties -> Computer 
Name -> Domain:

xencloud.net 

Reboot the server.
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Certificates:
Select the Base 64 radio button.

Download CA Certificate.

Save it to a directory on the 
C:\drive.

Certificates: 
Install the Domain Controller 
certs on the DDC.

Open an Internet Browser.

Navigate to http://vDesktopDC/
certsrv

Select Download CA Certificate, 
Certificate Chain or CRL.
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Import Certificate: 
Expand Console Root.

Select Trusted Root Certificates 
-> All Tasks -> Import.

Import Certificate: 
Run the Certificate MMC 
Console created in the base 
image.  

c:\console1.msc.

The Certificates console can 
also be accessed by the 
following:

Start -> Run -> mmc.exe -> 
File -> Add/Remove Snap-In 
-> Add -> Certificates -> Add 
-> Computer Account -> Next 
-> Local Computer -> Finish -> 
Close.
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DDC Install:
Place the Desktop Delivery 
Controller installation media 
into the CD/DVD drive via the 
XenCenter console.

Note: In this example, we 
extracted the DDC and PVS 
ISO Images into a directory, 
and created a CIFS Storage 
Repository in XenCenter.

The DDC ISO Image can then 
be mounted in the XenCenter 
Console, in the DDC CD/DVD 
drive.
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DDC Install:
Launch the DDC installer.

Select Install Server 
Components.

Select the components to 
install.
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DDC Install:
Create a new farm:

XenDesktopFarm

DDC Install:
Select License Entitlement.
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DDC Install:
Start the install.

You will likely need to reboot as 
part of the installation process.

Note: After reboot, you may 
need to launch the DDC installer 
again, to resume installation of 
remaining components.

DDC Install:
Create a new database.
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DDC Install:
Ignore the driver warnings, 
select Continue Anyway.

DDC Install:
When setup completes, 
leave both boxes checked to 
create the Active Directory 
Organizational Unit (OU).

Select Finish.
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DDC Install:
Select the Active Directory OU 
configure in a previous step.

DDC Install:
The Active Directory 
Configuration Wizard starts.

Note the AD Configuration 
Wizard can also be run from the 
Windows Start menu.
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Licensing:
Open a Command window and 
find out what the hostname is 
by typing in ‘hostname’.

It is important to specify the 
case sensitive hostname when 
activating your license from 
MyCitrix.com.

Activate and download the 
Citrix XenDesktop license from 
MyCitrix.com.

Licensing:
Launch the License 
Management Console:

Start -> Citrix -> Management 
Consoles -> License 
Management Console.

Select Configure License 
Server.

Select Copy license file to this 
license server.

Browse and Upload the license 
file.
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Provisioning Server - vDesktopPVS

Create the Provisioning Server.

Provisioning Server:
From XenCenter select -> VM 
-> New VM.

Select the W2K3 x32 Base 
Image created in the previous 
step.

Name: vDesktopPVS

vCPUs: 2

Memory: 2048 Mb

Network: Interface 0 (minimum)

Follow the prompts to complete 
the sysprep install.

Don’t join the Domain yet.

Login as the local Administrator.
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Network Settings:
Open the Network Settings in 
the Control Panel.

Assign a static IP Address to 
the Network Interface.  

In this example:

IPA: 10.217.104.202

NMK: 255.255.255.0

GWY: 10.217.104.1

DNS: 10.217.104.200

Note: Disable the firewall.

XenTools: 
Install XenTools.

Select the vDesktopPVS from 
XenCenter left panel -> Right-
Click -> Install XenServer Tools.
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Join Domain: 
Join the Domain.

Start -> My Computer -> Right-
Click -> Properties -> Computer 
Name -> Domain:

xencloud.net 

Reboot the server.

vDisk Storage: 
You will need to ‘Add’ additional 
storage to the Provisioning 
Server to store the vDisk 
images.  

To calculate how much storage 
to allocate, start by estimating 
the size of the Operating 
System that will be installed 
on the vDisk.  For example: 
Windows XP = 10 Gb, Windows 
7 = 25 Gb.

A rule of thumb is to make 
3 vDisks to hold 3 copies of 
each Operating System for 1) 
Currently being used vDisk 2) 
A previously working vDisk 3) 
A new vDisk to add upgrades, 
patches, hotfixes, etc.

So for a Windows XP Desktop 
environment we will add 10Gb x 
3 = 30 Gb minimum.

For a Windows 7 Desktop 
environment, we will add 35 Gb 
x 3 = 105 Gb minimum.

Select the Storage tab in 
XenCenter for vDesktopPVS 
and Add.

In this example we added an 
additional 150 Gb for Windows 
7 vDisks.
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Remote Desktop: 
Connect to the PVS using RDP.

From the XenCenter PC, Start 
-> Run -> cmd.exe.

Within the command prompt 
window, launch Microsoft 
Terminal Services:

c:\mstsc /console

Enter the IP Address of the 
PVS.

Note: Make sure you login to 
the Domain, and not the local 
computer account.
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Initialize vDisk Partition: 
Start -> Administrative Tools -> 
Computer Management.

Select Disk Management -> 
Right-Click the new disk -> 
New Partition.

This partition will hold the 
Windows 7 vDisks. (150 Gb).

Note: In this example, we also 
added another partition for 
Windows XP vDisks (50 Gb).

These partitions are added as 
separate volumes, so that you 
can go back and extend them 
later.
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Certificates:
Select the Base 64 radio button.

Download CA Certificate.

Save it to a directory on the 
C:\drive.

Certificates: 
Install the Domain Controller 
certs on the PVS.

Open an Internet Browser.

Navigate to http://vDesktopDC/
certsrv

Select Download CA Certificate, 
Certificate Chain or CRL.
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Import Certificate: 
Expand Console Root.

Select Trusted Root Certificates 
-> All Tasks -> Import.

Import Certificate: 
Run the Certificate MMC 
Console created in the base 
image.  

c:\console1.msc.

The Certificates console can 
also be accessed by the 
following:

Start -> Run -> mmc.exe -> 
File -> Add/Remove Snap-In 
-> Add -> Certificates -> Add 
-> Computer Account -> Next 
-> Local Computer -> Finish -> 
Close.
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PVS Install:
Place the Provisioning Server 
installation media into the CD/
DVD drive via the XenCenter 
console.

Note: In this example, we 
extracted the DDC and PVS 
ISO Images into a directory, 
and created a CIFS Storage 
Repository in XenCenter.

The PVS ISO Image can then 
be mounted in the XenCenter 
Console, in the PVS CD/DVD 
drive.



DEPLOYMENT GUIDE  |  XenDesktop

42

PVS Install:
From the PVS, navigate to 
d:\SQL Server 2005 Express on 
the PVS Installation media.

Install SQL Server Express.

Use the defaults.

Restart before continuing.

Install the Console 
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PVS Install:
Install the Server.

When the wizard prompts for 
DHCP services, select The 
service that runs on another 
computer.

When the wizard prompts for 
PXE services, select The service 
that runs on this computer.
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PVS Install:
Create a Farm.

When prompted for Database 
Server:

Click on Browse, select 
VDESKTOPPVS, and Ok.

Click Next.
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PVS Install:
When prompted for New Farm:

The Farm Name is a different 
farm than the one created on 
the DDC.

PVS Install:
When prompted for License 
Server:

Enter the name of the DDC 
server.
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PVS Install:
When prompted for User 
Account:

Use the Administrator account 
and check the box for Configure 
the database for the account.

PVS Install:
When prompted for Stream 
Services:

Select the network card and 
ports - use the defaults.
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PVS Install:
When prompted for TFTP 
Option:

Select Use the Provisioning 
Server TFTP service.

PVS Install:
Boot List:

Use the default.
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PVS Install:
Finish.

The log file can be found in:

c:\Documents and Settings\All 
Users\Application Data\Citrix\
Provisioning Services\Log\
ConfigWizard.log

vDisk creation:
From the XenCenter Console, 
select vDesktopPVS, and 
mount the DDC Installation 
media in the CD/DVD drive.
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vDisk creation:
From vDesktopPVS, navigate 
on the DDC installation CD to 
d:\w2k3\en\XenDesktop Setup 
Tool.

Copy these files from the 
CD/DVD to the vDesktopPVS 
server.

Run Setup.exe and Install.

vDisk creation:
On the additional disk added to 
vDesktopPVS to store vdisks, 
add a subdirectory.

f:\XDStore-Win7
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vDisk creation:
From the Start Menu -> Citrix 
-> Provisioning Services -> 
Provisioning Services Console.

vDisk creation:
Right-Click -> Connect to Farm.

Specify the FQDN of the PVS 
server. ex: vDesktopPVS.
xencldoud.net.
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vDisk creation:
Expand the tree, Right-Click on 
Stores -> Create Store.

Select the Paths tab, and enter 
the location of the directory 
store. F:\XDstore-Win7

vDisk creation:
Select the Servers tab.

Select VDESKTOPPVS.
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vDisk creation:
Under the General tab give the 
store a name, and select ‘Site’ 
as the owner.

vDisk creation:
Select XDstore -> Create 
vDisk...

Site: Site

Store: XDstore

Server used to create vDisk:

VDESKTOPPVS

Filename: vDisk-Windows7

Desc: Master vDisk for 
Windows 7 Desktops

Size: 36000 MB

VHD Format: Fixed

Note: Create the vDisk with 1~2 
Gb more than the size of the 
Windows 7 Virtual Machine.  Ex: 
Our Win7 VM = 35 GB, so our 
vDisk = 36 Gb.
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vDisk creation:
In the right panel of Provisioning 
Services Console, Right-Click 
the newly created vDisk.

Select Properties -> Edit File 
Properties.

Check the box for Active 
Directory machine account 
password management.

Ok.

Ok.

vDisk creation:
In the left panel, expand Sites.

Select the Servers object.

In the right panel, Right-Click 
VDESKTOPPVS.

Select Properties -> Options.

Check the box to Enable 
automatic password support.

Ok.

Restart the stream service.
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vDisk creation:
In the left panel of the 
Provisioning Service Console 
select XDstore-Win7.

In the right panel Right-Click 
the vDisk-Windows7 -> Mount 
vDisk.

vDisk creation:
Open Disk Management from 
the Computer Management 
Console in vDesktopPVS.

Right-Click -> Format.

Note: Assign a drive letter 
before formatting. ex: V:

When finished, go back to the 
PVS Console and Unmount the 
vDisk.



Virtual Desktop

To create the Virtual Desktop, a base Windows 7 image will be created. This 
will be used to create the Windows 7 vDisk.
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vBaseDesktop1:
Create a new VM of Windows 7.

Note: The OS can be installed 
from the XenServer CD/DVD 
Drive or an ISO image.

Name: Win7 Base Image

vCPUs: 4

Memory: 4096 Mb

Disk: 32 Gb

Network: Interface 0 (minimum)

Right-Click Win7 Base Image in 
the left panel of XenCenter.

Install XenServer Tools.

Log into the win7 Base Image 
and launch the installer from the 
CD drive.

Reboot.
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vBaseDesktop1:
Add the Xencloud.net domain 
to the DNS suffix option.

Open Network Settings -> Local 
Area Connection properties -> 
IPv4 -> Advanced -> DNS.

Set the DNS suffix for this 
connection to xencloud.net.

Ok.

Ok.

Close.

vBaseDesktop1: 
Join the XenCloud.net Domain.

My Computer -> Right-Click -> 
Computer Name -> Change.

Computer Name: 
vBaseDesktop1

Domain:

xencloud.net

Restart.
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vBaseDesktop1:
Launch the MMC. 

From the File menu select Add/
Remove Snap-In.

Add.

Certificates.

Add.

Select Computer Account, 
Local Computer.

Close the MMC and save to the  
C:\ drive.

vBaseDesktop1:
Disable the Firewall.
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vBaseDesktop1: 
Select Base 64.

Download CA Certificate.

Save to a convenient location.

vBaseDesktop1:
Install the Domain Controllers 
Root certificate.

Open a browser to http://
vDesktopDC/Certsrv

Login with domain credentials:

User: xencloud\administrator

Pass: <password>

Select Download CA certificate, 
certificate chain or CRL.
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vBaseDesktop1: 
Login to vBaseDesktop1 in the 
Domain account.

vBaseDesktop1: 
Open the MMC Console saved 
earlier.

Expand Certificates -> All Tasks 
-> Import.

Import the Domain Controllers 
Root Certificate.
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vBaseDesktop1: 
In the XenCenter Console, load 
the Desktop Delivery Center 
installation media into the 
CD/DVD drive of the Windows 
7 VM.

Launch the installer.

Install Virtual Desktop 
Components.

This installs the Virtual Desktop 
Agent.

vBaseDesktop1: 
Use the defaults.

Select the Farm created earlier.

Install.

Restart.
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vBaseDesktop1: 
Select the Network tab.

Write down the MAC Address of 
the Network.

In this example:

3a:ce:d3:00:c6:85

vBaseDesktop1: 
In the left panel of the 
XenCenter Console, select the 
vBaseDesktop1 object.

Right-Click -> Properties.

Select Startup Options.

Move Network to the top of the 
list.

Ok.
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vDesktopPVS: 
In the XenCenter Console, left 
panel, Select the vDesktopPVS 
object (Provisioning Server).

Note: Make sure you login to 
the Domain, and not the local 
computer account.

vDesktopPVS: 
Launch the Provisioning 
Services Console.

Right-Click -> Connect to Farm:

Enter the FQDN of the 
provisioning server.

ex: vDesktopPVS.xencloud.net
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vDesktopPVS: 
Expand the tree, and 
select Create Device under 
Collections.

Provisioning Services Console 
-> Farm -> Sites -> Device 
Collections -> Collections -> 
Right-Click -> Create Device.

Name: vBaseMasterTarget

Desc: Master Image

MAC: <MAC Address recorded 
earlier> 

ex: 3a:ce:d3:00:c6:85

Ok.

PVS VM Template: 
In the right panel, select the 
new device, Right-Click -> 
Properties.

Select the vDisks tab.

Click Add.

Select the XDstore-Win7/vDisk-
Windows7 image.

Select the General tab.

Boot from: Hard Disk.

Ok.
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PVS VM Template: 
Select the XDstore-Win7.

If the vDisk is locked, you must 
unlock it.

Shutdown vBaseDesktop1 from 
the XenCenter Console.

In PVS, Right-Click the vDisk -> 
Manage Locks -> Unlock.

vBaseDesktop1: 
Install the Provisioning Services 
Target Device software.

Login to the vBaseDesktop1 
from the XenCenter Console.

Note: Make sure you login as 
the Domain Administrator and 
not the local computer account.

For the vBaseDesktop1 VM, 
in XenCenter load the PVS 
installation media into the CD/
DVD drive.

Note: If using PVS 5.1 SP2, 
there is no ISO, you must 
copy the zip file to the 
vBaseDesktop1 and unzip the 
contents.

The Previsioning Services 
Target Device software is in the 
d:\Device directory.
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vBaseDesktop1: 
Open the Virtual Disk icon in 
the system tray and confirm the 
vDisk status is Active.

vBaseDesktop1: 
When finished the 
vBaseDesktop1 should have 
the following installed.

Citrix Provisioning Services Tar-
get Device

Citrix Virtual Desktop Agent 

Citrix Tools for Virtual Machines

Citrix XenConvert

Optional:

Citrix Online plugin

Citrix Branch Repeater

•

•

•

•

•

•
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vBaseDesktop1: 
If you are planning on using the 
Branch Repeater Client, then 
you must install it after installing 
the Provisioning Services Target 
Device software.

In this example, we have the 
BR VPX at both the Client 
and Server side doing the 
acceleration, so we don’t load 
the BR Client software.

vBaseDesktop1: 
Run XenConvert.

Note: Download and run the 
latest XenConvert software from 
citrix.com -> Downloads -> 
XenServer -> XenConvert.

From:

This Machine

To:

Provisioning Services vDisk
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vBaseDesktop1: 
If you are going to use this 
Desktop in combination with a 
Branch Repeater solution, and 
you are going to use the Branch 
Repeater Client, now is a 
good time to install the Branch 
Repeater Client.

Shutdown the vBaseDesktop1 
system from the XenCenter 
Console.

vBaseDesktop1: 
In the Provisioning Services 
Console on the vDesktopPVS 
system, navigate to the vDisk, 
select Properties, and click Edit 
Device Properties.

Select Mode.

Set Access Mode to Standard 
Image.

Ok.

Ok.
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vBaseDesktop1: 
Reboot the vBaseDesktop1 
from XenCenter.

When the Master Target 
reboots, it should boot from the 
network.
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XenDesktop Setup: 
From the Provisioning Server 
(vDesktopPVS), launch the 
XenDesktop Setup Wizard.

XenDesktop Setup: 
Desktop Farm:

XenDesktopFarm
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vBaseDesktop1: 
Select the PVS VM Template.

vBaseDesktop1: 
Select Citrix Xen VM 
Infrastructure.

Set the Address field to your 
XenServer.  

ex: http://10.217.104.12

Login to the XenServer that is 
hosting the Virtual Desktops.
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XenDesktop Setup: 
Select the vDisk-Windows7.

XenDesktop Setup: 
Use the Default OU.
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vBaseDesktop1: 
As you finish, you will see the 
virtual desktops being created 
in XenServer, in the XenCenter 
Console, left panel.

vBaseDesktop1: 
Create a new desktop group.

XDGroup.
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Delivery Services: 
Login to the Desktop Delivery 
Controller (vDesktopDDC).

Note: Make sure you login as 
the Domain Administrator and 
not the local computer account.

Delivery Services: 
Run the Delivery Services 
Console.

Configure and run discovery.
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vBaseDesktop1: 
As you finish, you will see the 
virtual desktops being created 
in XenServer, in the XenCenter 
Console, left panel.

Delivery Services: 
Expand the Desktop Groups 
and select the XDGroup created  
in an earlier step.
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vDesktopDC: 
On a File Server in the domain, 
create a users directory.

Turn on sharing for this 
directory.

vDesktopDC:
In Active Directory, open the 
users profile, under home folder, 
select Connect.

Use a drive letter that is not in 
use, and that will not conflict 
with XenDesktop or XenApp 
drive mappings.

Enter the location:

\\<file server>\users\%username%

Mapping Network Drives

Because XenDesktop uses a shared image to deliver the operating system, us-
ers will need to save their data to a network drive.  You set this up in the 
profile of the user, and in a policy on the DDC.
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vDesktopDC:
When the user logs into their 
Desktop, open Computer and 
you should see the network 
drive mapping.  

vDesktopDDC: 
From the vDesktopDDC, 
launch the Presentation Server 
Console.

Navigate to Policies.

Right-Click -> Create Policy.
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vDesktopDDC: 
Navigate to Client Devices 
-> Resources -> Drives -> 
Mappings.

Enabled

Apply

Ok

•

vDesktopDDC: 
Open the newly created policy.

Navigate to Client Devices 
-> Resources -> Drives -> 
Connection.

Enabled

Connect Client Drives at Logon

Apply

•

•
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vDesktopDDC: 
Right-Click the new policy -> 
Apply this policy to...

Virtual Desktop Group Name

Filter base on virtual desktop 
group name

Apply to all virtual desktop 
groups

•

•

•
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vDesktopDDC: 
You can see these by opening 
the Citrix Web Interface 
console.

vDesktopDDC:
Web Interface users connect to 
the Internal Site.

Testing XenDesktop

XenDesktop can be access through a Web Interface or through the Citrix 
Receiver. The Web Interface site and Receiver site is already configured in the 
DDC.
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vDesktopDDC:
Receiver users connect to the 
PNAgent Site.

Client Device: 
To test XenDesktop from a web 
browser, on the Client Device, 
open a web browser and type in 
this URL:

http://vDesktopDDC.<your 
domain>
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Client Device: 
To test XenDesktop from the 
Online Plugin, install the Online 
Plugin on the Client Device.

Client Device:
Enter Login Credentials.
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Client Device:
Whether connecting through 
the Web Interface -or- Online 
Plugin, XenDesktop is delivered 
to the Client Device.

Client Device: 
If you installed the Online Plugin 
into the base vDisk image, 
then you can run XenApp 
applications from within this 
Desktop, such as Microsoft 
Office.
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